DSI Time Sync could not be started Error 1053 when using Ponemah v5.X on Windows 10
Symptom
The DSI Time Sync Service is installed but does not start. Attempting to start the service manually results in the following error:
Windows could not start the DSI Time Sync service on the Local Computer.
Error 1053: The service did not respond to the start or control request in a timely fashion.
Cause
Some Windows 10 PCs do not natively include all the prerequisite files required for the DSI Time Sync service to run. The user may see an issue during the installation that states that the DSI Time Sync service cannot be started.
If the user hits OK, the install finishes with no impact to those users not using a sync system.
If the user wishes to use the Sync feature, the 32-bit redistributable must be manually installed to the PC.
Solution
The solution is to run the vc_redist.x86.exe executable that is located in the “Redistributables” folder from the Ponemah v5.32 install USB/folder.
The Redistributables folder contains two executables:
- vc_redist.x64.exe
- vc_redist.x86
Run the vc_redist.x86.exe program to install the missing files and allow the DSI Time Sync service to run.
Alternatively, the vc_redist.x86.exe program may be downloaded from the following location, under the Visual Studio 2017 header:
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
Once the file is installed, the user will be prompted to restart the PC and the service will automatically be started after the reboot.
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